Degraded PDS performance
Incident Report for Bluesky Social
Resolved
There should be no further issues.
Posted Aug 18, 2023 - 14:04 PDT
Identified
We have fixed the main problem. Some images may not be loading. Fix in process.
Posted Aug 18, 2023 - 12:23 PDT
Investigating
We are currently investigating this issue.
Posted Aug 18, 2023 - 09:47 PDT
This incident affected: Bluesky PDS.